LTS

    Innovation Version

      Upgrade Methods

      • For an upgrade between patch versions of a major version, for example, upgrading 2.x.x to 2.x.x, run the following command:

        $ sudo yum update -y iSulad
        
      • For an upgrade between major versions, for example, upgrading 1.x.x to 2.x.x, save the current configuration file /etc/isulad/daemon.json, uninstall the existing iSulad software package, install the iSulad software package to be upgraded, and restore the configuration file.

      NOTE:

      • You can run the sudo rpm -qa |grep iSulad or isula version command to check the iSulad version.
      • If you want to manually perform upgrade between patch versions of a major version, run the following command to download the RPM packages of iSulad and all its dependent libraries:
      $ sudo rpm -Uhv iSulad-xx.xx.xx-YYYYmmdd.HHMMSS.gitxxxxxxxx.aarch64.rpm  
      

      If the upgrade fails, run the following command to forcibly perform the upgrade:

      $ sudo rpm -Uhv --force iSulad-xx.xx.xx-YYYYmmdd.HHMMSS.gitxxxxxxxx.aarch64.rpm  
      
      • iSulad uses the lcr as the default container runtime in versions earlier than openEuler 22.03 LTS SP3. After a cross-version upgrade, the containers created before the upgrade still use the lcr as the runtime, and the containers created after the upgrade use the default runtime runc in the new version. If the lcr container runtime still needs to be used in the new version, change the value of default-runtime in the default iSulad configuration file (/etc/isulad/daemon.json) to lcr or specify the lcr as the runtime (--runtime lcr) when running a container.

      Bug Catching

      Buggy Content

      Bug Description

      Submit As Issue

      It's a little complicated....

      I'd like to ask someone.

      PR

      Just a small problem.

      I can fix it online!

      Bug Type
      Specifications and Common Mistakes

      ● Misspellings or punctuation mistakes;

      ● Incorrect links, empty cells, or wrong formats;

      ● Chinese characters in English context;

      ● Minor inconsistencies between the UI and descriptions;

      ● Low writing fluency that does not affect understanding;

      ● Incorrect version numbers, including software package names and version numbers on the UI.

      Usability

      ● Incorrect or missing key steps;

      ● Missing prerequisites or precautions;

      ● Ambiguous figures, tables, or texts;

      ● Unclear logic, such as missing classifications, items, and steps.

      Correctness

      ● Technical principles, function descriptions, or specifications inconsistent with those of the software;

      ● Incorrect schematic or architecture diagrams;

      ● Incorrect commands or command parameters;

      ● Incorrect code;

      ● Commands inconsistent with the functions;

      ● Wrong screenshots.

      Risk Warnings

      ● Lack of risk warnings for operations that may damage the system or important data.

      Content Compliance

      ● Contents that may violate applicable laws and regulations or geo-cultural context-sensitive words and expressions;

      ● Copyright infringement.

      How satisfied are you with this document

      Not satisfied at all
      Very satisfied
      Submit
      Click to create an issue. An issue template will be automatically generated based on your feedback.
      Bug Catching
      编组 3备份