安装obs工具

介绍

OBS(Open Build Service)是通用编译工具,用于将源码包构建为 RPM 软件包或 Linux 镜像。 obs-server 是 OBS 对应的软件包。

架构适配

支持在多种架构平台(x86_64、AArch64 等)上使用。

安装

此处以 openEuler 22.03 LTS 版本的 AArch64 架构为例,介绍 obs-server 多版本分支软件包的安装操作。

  1. 确认设备已安装操作系统 openEuler 22.03 LTS。

    $ cat /etc/openEuler-release
    openEuler release 22.03 LTS
    
  2. 配置 yum 源,obs-server 多版本的 repo 源要放置于 everything 的 repo 源前面。yum 源配置内容参考如下:

    [obs]
    name=obs
    baseurl=https://repo.openeuler.org/openEuler-22.03-LTS/EPOL/update/multi_version/obs-server/2.10.11/aarch64/
    enabled=1
    gpgcheck=0
    
    [everything]
    name=everything
    baseurl=https://repo.openeuler.org/openEuler-22.03-LTS/everything/aarch64/
    enabled=1
    gpgcheck=0
    

    执行下述命令拷贝上述文本到 repo 源中:

    $ sudo vi /etc/yum.repos.d/xxx.repo
    
  3. 使 yum 源生效。

    $ sudo yum clean all
    $ sudo yum makecache
    
  4. 检查是否已安装其他版本的软件包。

    $ sudo rpm -qa obs-server obs-common obs-api mod_passenger obs-api-deps obs-bundled-gems passenger ruby ruby-help ruby-irb rubygem-bundler rubygem-io-console rubygem-json rubygem-openssl rubygem-psych rubygem-rake rubygem-rdoc rubygems rubygem-bigdecimal rubygem-did_you_mean
    
  5. (可选)如果有其他版本的软件包,请卸载软件包防止安装冲突。

    $ sudo yum remove -y obs-server obs-common obs-api mod_passenger obs-api-deps obs-bundled-gems passenger ruby ruby-help ruby-irb rubygem-bundler rubygem-io-console rubygem-json rubygem-openssl rubygem-psych rubygem-rake rubygem-rdoc rubygems rubygem-bigdecimal rubygem-did_you_mean
    

    注意事项:

    • 该分支作为 openEuler 22.03 LTS 版本发布的 obs-server 多版本分支
    • 安装依赖包可能由于存在多个版本,导致依赖冲突安装失败。所以安装前先卸载上述软件包
  6. 安装 obs-server 相关软件包。

    $ sudo yum install -y obs-api obs-server
    
  7. 检查 obs-server 软件包安装成功。

    $ rpm -qa | grep obs-server
    obs-server-2.10.11-6.oe2203.noarch
    $ rpm -qa | grep obs-api
    obs-api-2.10.11-6.oe2203.noarch
    

部署

  1. 获取部署脚本,具体请参见获取链接: https://gitee.com/openeuler/infrastructure/tree/master/obs/tf/startup

  2. 执行 restart_service.sh 脚本部署 OBS 工具。

使用说明

可以通过 OBS 网页和osc命令的方式构建RPM软件包。详细内容可参考《构建RPM包》文档: https://gitee.com/openeuler/docs/blob/stable2-22.03_LTS/docs/zh/docs/ApplicationDev/%E6%9E%84%E5%BB%BARPM%E5%8C%85.md

文档捉虫

“有虫”文档片段

问题描述

提交类型 issue
有点复杂...
找人问问吧。
PR
小问题,全程线上修改...
一键搞定!
问题类型
规范和低错类

● 错别字或拼写错误;标点符号使用错误;

● 链接错误、空单元格、格式错误;

● 英文中包含中文字符;

● 界面和描述不一致,但不影响操作;

● 表述不通顺,但不影响理解;

● 版本号不匹配:如软件包名称、界面版本号;

易用性

● 关键步骤错误或缺失,无法指导用户完成任务;

● 缺少必要的前提条件、注意事项等;

● 图形、表格、文字等晦涩难懂;

● 逻辑不清晰,该分类、分项、分步骤的没有给出;

正确性

● 技术原理、功能、规格等描述和软件不一致,存在错误;

● 原理图、架构图等存在错误;

● 命令、命令参数等错误;

● 代码片段错误;

● 命令无法完成对应功能;

● 界面错误,无法指导操作;

风险提示

● 对重要数据或系统存在风险的操作,缺少安全提示;

内容合规

● 违反法律法规,涉及政治、领土主权等敏感词;

● 内容侵权;

您对文档的总体满意度

非常不满意
非常满意
提交
根据您的反馈,会自动生成issue模板。您只需点击按钮,创建issue即可。